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Getting Started with P4V

P4V, the Perforce Visual client, is Perforce’s cross-platform graphical user interface. You
can use P4V on Windows, Macintosh, UNIX and Linux computers and benefit from an
identical interface regardless of platform. This introductory guide provides some Perforce
basics and an orientation to P4V’s layout and features. For more details about P4V,
consult its online help. To learn more about Perforce, consult the user documentation on
our Web site.

To use Perforce to manage files, you typically connect to a Perforce server using a client
program like P4V. P4V enables you to check files in and out, and perform the various
other necessary tasks. The following sections tell you how to perform basic tasks and
point out powerful features and shortcuts.

Basic Concepts

P4V connects your computer to a Perforce server to move files between Perforce depots and
your workspace, as shown below.

Workspaces store ..your computer, ..the Perforce Server ...depots, repositories
local copies of files running P4V, which  on a central server of files under
on... connects to... machine, which Perforce control
manages...
£ =
%
El[——n 7 |
] % % % (client application) (server)
(workspace) (depot)

The definitions for these Perforce terms are as follows:

¢ Workspace: folders or directories on the client computer where you work on revisions
of files that are managed by Perforce.

¢ Client application: P4V (or another Perforce client application), running on your
computer, sending commands to the Perforce server and receiving results (files, status
information, and so on).
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Connecting to a Server

e Server: the program that executes the commands sent by client programs, maintains
depot files, and tracks the state of workspaces. The Perforce Server typically runs on a
central machine, connected to client machines by the network.

¢ Depot: a file repository on the Perforce server. It contains all existing versions of all files
ever submitted to the server. There can be multiple depots on a single server. The
examples in this guide show a single depot.

Connecting to a Server

To gain access to your depots, you must connect to a server. To connect to a server:

1. Launch P4V. P4V displays the following connection dialog:

2] Open Connection g|
Recent connections: A 3&'
Connect ko

Server:
User: tonyz ’ Browse. .. ] ’ Mew. .. ]
Warkspace: | (opfional) ’ Browse, .. ] ’ Mew, .. ]

Show dialog at startup

I OF H Cancel ” Help ]

Version:  Perforce Visual Client/NTX86/2008, 1

2. Specify the following settings (your Perforce administrator can provide you with this
information)

¢ Server: the name of the computer where your Perforce server is running.
¢ Port: the port number assigned to the server

® User: your Perforce user name

e Password: your Perforce user password, if required.

e Workspace: the name of your client workspace.

To display a list of existing users and workspaces, click Browse. (The server and
port must be specified before clicking Browse.)

If you have incorrectly specified a server setting, P4V displays a message like the
following:

Connect to server failed; check S$P4PORT.
TCP connect to bigserver failed.
bigserver: host unknown.
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Connecting to a Server

3.

Bl play:1999, tonyz - Perforce P4V

File Edit View Connection Tools  Window  Help

R A I BRR O BERE 200328 Q

To connect, click OK. P4V displays its main screen, as shown in the following figure.

v/ .

P2 Depat Tree B, SE || & Fiesin Folder
@ {no workspace selected) v|
o i

Details Checked Out By

Preview

H & 8

‘Workspace location:
Depot location:
Revision:

Date modified:

File: size:

Type:

Perforce filetype:

8 Depot B2 workspace & Files | A Pending

=22 Log

p4 login -5
login' not necessary, no password set for this user,

The next section describes the main screen panes.
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Navigating the Main Screen

Navigating the Main Screen

The following figure points out the panes and important features of the main screen. To see
what a button or screen element does, hold the mouse cursor over it. P4V displays a
descriptive tooltip.

2] play:1999, tonyz - Perforce P4V

File Edit View Connection Tools ‘Window  Help
B d 48R 2 U0 BER24AB3 A& 0

v| @,
P2 Depot Tres B, || 2 Fiesin Folder H. & 8

I3 tro workspacs sslected) -
“a 4 ~@—1 Files in folder: lists the files in the
folder you are browsing in the left
You can display thumb-

T nails of image files in this pane by
i Mp— choosing View> Show Files As.

Ravision:

Dffais | checked OutBy | Preview

Dfe modified:

rf s <— Right pane: displays Perforce

T specifications and file
information. To select the

©8 veeo: | B workspnce Ar A e specification you want to display,
choose the View menu item or
click the corresponding toolbar
button.

Pofforce filetype:

Left pane: displays files Log pane: displays the Perforce commands
and folders. The Depot tab that P4V issues, plus error messages and
displays files in the results.

Perforce server, and the

Workspace tab displays

files in the workspace on
your computer

Setting up your workspace

Your Perforce administrator can do this for you, but it’s advisable to learn a few important
aspects of configuring your workspace, specifically (1) configuring the client root
directory and (2) configuring the client view.

To define a workspace, choose Connection > New Workspace.... To edit your current
workspace specification, choose Connection > Edit Current Workspace...
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Setting up your workspace

P4V displays the specification details in the lower portion of the right pane; for example:
= Workspace: tonyz-test (play:1999, tonyz) : :f’gl

Form | View

Description: | Created by tonyz.

Root: [N \paclientsitanyz-test]
NltRoots:

Options:
[ alwrite [ clobber  [] compress [ locked [ modtime [ rmdir

SubmitOptions: [submitunchangsd ¥

( Wiew: ydepntt... Jftonyz-test/depot/. .

N

o ][ o ][ e ]

Root: specifies the location on
your computer under which Perforce
stores copies of depot files. Specify a
meaningful name, and make sure it’s
not set to your computer’s root
directory!

View: enables you to restrict the
depot files to which you have access.
Set the view to ensure that you see
only what you need to see.
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Setting up your workspace

To display and set the client view graphically, click the View tab. Browse to desired files
and folders and context-click to include them or exclude them from the client view, as
shown in the following figure.

= Workspace: tonyz-test (play:1999, tonyz) |:||§|E|

Farm " Wigw |

Workspace Root: | etlpaclientsitonyz-test | Browse. ..

Depok Tree Client Expression
= &
B8 %
5 — |
0 Ace W
£ antt Exclude Tree
O arch Include Files
Ot e i
v depr Euae Flles Htonyz-testidepat/...
O depr Include Special...
Ol oms Exclude Special...
0 glare

O gue: Refresh '
0 messagegate
) oldspecs
) perforce
ﬁ pitstop

ﬁ remoke

ﬁ specl

ﬁ spec?

ﬁ specl

£ stuffz

) wif

L o e e e e e 2 )

OF H Cancel ” Apply
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Managing your Files

Managing your Files

To manage files using Perforce, you typically perform the following sequence of tasks:
1.  Get files from the depot.

2. Check out files you need to edit.

3. Edit files.

4. Check in your changes.

The following sections provide details about these and other common file management
tasks.

Getting files from the depot
To copy files from the depot to your workspace:
1. In the left pane, click the Depot tab.
2. Browse to the folder or file you want to retrieve.

3. Context-click the file or folder. To get the most recent version, choose Get Latest
Revision. To get an older version, choose Get Revision... and specify the version you
want.

In the Log pane, P4V displays a message like the following.

p4 sync //my-test-workspace/main/bark
//depot/main/bark#2 - added as c:\p4clients\my-test-workspace\main\bark
sync complete. 1 file affected.

In the left pane, note that the file displays a green dot, indicating that it is present in your
workspace: - [ park #2/2 ctets

Now the file resides in your workspace. If you want to edit the file, you must first check it
out.
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Managing your Files

Checking out files from the depot
To check out a file in your workspace:
1. Browse to the desired file in the left pane Depot tab.
2. Context-click the file and choose Check Out.

In the Log pane, P4V displays a message like the following:

p4 edit //my-test-workspace/main/bark
//depot/main/bark#2 - opened for edit

In the left pane, note that the file displays a red check mark, indicating that you checked it
out: B bark #2/2 ctests
Note that, when you check out a file, Perforce adds it to a changelist, which is a list of

related files. You can use changelists to group related files, for example, all files that
contain changes required to implement a new product feature. To view the changelist,

choose View > Pending Changelists or click g in the toolbar.

Now you're ready to edit your files.

Editing files in your workspace

To edit a checked-out file, double-click it (or context-click it and choose Open With..., then
select the desired application). P4V launches the corresponding editing application. Make
changes and save the file.

To select an application with which to open a file, choose File>Open With...>Choose
Application. Note that you can configure editors for different file types by choosing
Edit > Preferences... and clicking the Editors tab.

Diffing files to view your edits

To enable you to see what changes you’'ve made, you can compare (diff) your edited file
with the version you checked out. To diff, context-click the checked-out file in the left

12 Perforce 2008.1 Getting Started with P4V



Managing your Files

pane and choose Diff Against Have Revision. P4V launches P4Diff, displaying the
differences between the two files. For example:

B] p4Merge - barley.ixt and barfly.txt E]E|E|
File Edit Yew Find Help

1 4 IR 4,

3 diffs (Ignore line ending differences) | Tab spacing: 7 | Encoding: UTF-8

sdclientshsubmariner-play-133934mainsbarley. tut wpdclientstzubmaniner-play-199%mainbarfly st #*
ooblek fan apple apple ape vo ooblek fan left rubber wvo-vo
lemur ape bonk tiki chipmunk lemur hog fan left lawva tiki
rubber right left rubber wvo-w
lemur hog fan left lava blah zebra, chita, clowver, honew,
zebra, chita, clover, honev, e gle =] w
rubber wo-wvo rubber vo-wo rub revision 3

rubber wo-vo rubber wvo-wo rub
zebra, chita, clover, honev,
barley barley barlew

Discarding edits by reverting
If you decide you want to discard your changes:

1. Context-click the file in the left pane and choose Revert. P4V displays a warning
dialog.

2. Click OK. In the Log pane, P4V displays a message like the following;:

p4 revert //my-test-workspace/main/bark
revert complete. 1 file affected.

Checking your edits into the depot

To check your changed file into the depot, perform the following steps.
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Managing your Files

1.

Display pending changelists: click A in the toolbar. P4V displays a list of pending
changelists, as shown in the following figure. To display the files in a changelist,

expand it
A Pending Changelists
Client ‘Workspace Changelists: [myp-test-workspace] Vl .J],
Changelist Uszer Description
J default
A 7964
A~
Change: new F
D ate:
Client: my-test-work space 0
Uszer: tonyz
Statusz: hew
b
12y Files | A Pending | x

Double-click the changelist in which your file i
shown in the following figure.

4 Submit Changelist: default

W Write a changelist description:

W Choose files to submit:

O Mame In Falder Type Action
B  bark j{depat File edit

On submit:| Submit all selected files ~ [ check out submitted files after submit

I Link jobs to changelist (optional):

St | v o e change

s open. P4V displays the details, as

Enter a description explaining the changes you made and click Submit. The Log

pane displays a message confirming that your
the following.

changelist was submitted, similar to

Change 7941 submitted.
submit complete. 1 file affected.

14
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Graphical Reporting Tools

Displaying a file’s revision history

To view the changes made to a file or folder, context-click the file or folder and choose File

History or Folder History. The history for the selected file or folder is displayed in the

right pane. For example, the following figure shows the history of a folder, listing every
submitted changelist that affected a file in the folder.

3 Falder Histary

Fievizion [Changelist] [rate Submitted Submitted By

200412/0312:2855  joreas

45262

A 5261 2004/12/0312:27:40  jcreas
45260 2004/12/0312:04:21  weisz
415259 2004/12/0311:46:08  jcreas
45258 200412/0311:31:02  weiss
45257 2004/12/0311:30:30 weiss
245256 200412/0311:30:22 weiss
25255 2004/12/0311:30:06  weiss
215254 2004/12/0311:23:42  weiss
45253 200412/0311:2335  weiss
45252 200412/0311:2312  weiss
45251 2004/12/0311:2303  weiss
45250 2004/12/0311:28:53  weiss
215249 2004/12/0311:28:41  weiss
25248 200412/0311:28:27  weisz
5247 200412/0311:27:00  weiss
25245 200412/0311:21:53  weiss
215245

200412/0311:21:10  weiss

Graphical Reporting Tools

=

Description
Fename/Move: //depat/jamestest/atest3fafdg To: //depot/jamestest/atest3/...
Fename/Move: //depat/jamestest/atest3/ghafhifg.t«t To: //depotjamestest/a...
Adding Khizanth
Fename/Move: //depatjamestest/atest2/Copy [11] of testfile.tat To: //depots)...
Finizhed loga for approval.
Finizhed tree branches.
Added a bit more green in amongst pellow leaves.
Changed from spring to autumn leaves.
Finizhed mozaic.
Shifted tiles around ta better clarify image.
Finizhed map.
Made wriinkles deeper as per manager request,
Added wrinkles to map
Put water color back, manager didn't like.
Changed water color
Adding screenshot Baze data
Fename/Move: E:\perforcehgweiss_play\depothgweizs'PhotozhopPlugintgrad...

-

Fename/Move: E:\perforcehgweiss_playtdepothgweizsiPhotozhopPluginifoo. .. v

P4V includes several valuable graphical reporting tools:

¢ Revision Graph: displays a diagram that shows the evolution of a selected file,
including files related by branching operations.

¢ Time-lapse View: shows how the contents of a selected text file changed from revision
to revision. You can easily sweep through revision ranges to locate passages of interest
and see when they were created and how they changed.

¢ Folder diff tool: enables you to see how the contents of a folder changed.

The following sections provide more details about these tools.

Perforce 2008.1 Getting Started with P4V
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Graphical Reporting Tools

Viewing file revisions as a diagram

To display the revision diagram for a file, context-click the file in the left pane and choose
Revision Graph. P4V launches the tool, which displays a diagram like the following one.

B Revision Graph - [/depot/samicherry/bar (play:1999, tonyz)

File  Wiew Highlight Tools ‘Window  Help
L |>71 ¥ = e
G Fie Fiter Tres x| 16930 16931 16933 16934 16935
= [ OO fidepotisamicherry 1 H2 |
bar /,l’,l’depot,l’sam,l’cherry,l’bar x
foo e
(1 |28
Iidepatfsamfcherryfoo
Details | Integrations | Labels | Preview Mavigator | Legend
Revision: Iidepotfsamfcherryfbar#2
Date submitted: 06 3:21:12PM  Changelist: 16935 _|
Submitted by:  samwise Perforce filetype:  text / /’
Ackion: inteqgrate File size: 0.0KB ( | | | | :
Description: <enter descripsdftion here

This diagram shows you when the file was created and how it was branched, and enables
you to view details about each version submitted to the depot and navigate through the
graph using the navigation map. For more details about the information displayed in the
revision graph, consult P4V online help.
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Graphical Reporting Tools

Browsing file revisions using Time-lapse View

To browse the changes made to a text file, context-click the file in the left pane and choose
Time-lapse View. P4V launches the utility, which displays a screen like the following one.

2] Time-lapse View - #/depotfsamicherryffoo (play:1999, tonyz)

@, | Mode: [Single revision %] | Content range: |2 tolz 2| scale:[Revisions  v| & |J‘
Least recent " Most recent
Q g Slider: move to
sweep through
1 .. asdfasd: P
2 .. asdflkasidlfkilki revisions
Selection added: A
Detals | Intsgrations | Labels Detals | Integrations | Labels
Revision: lidepotisamjcherryifon#2 Revision;
Dats submitted: 36 3:20:21 PM Changelist: 16933 Date submitted: Changslist:
Submitted by samwiss  Perforcs Flstype: text Submitted by: Perforce filetyps:
Action: edit File size: 0.0k Action; File size:
Description:  enter descripsdftion here> A || Deseription:
-

Change detail: shows text that has been
added, changed, or deleted in a revision

Using Time-lapse View, you can sweep through all revisions of the file using the slider,

noting when changes were made and who made them. Again, for details, consult P4V
online help.
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Graphical Reporting Tools

Displaying folder history using the folder diff tool

The folder diff tool enables you to see how the contents of a folder have changed: which
files are added, changed, or deleted. To view changes to a folder:

1.  Context-click the folder in the left pane Depot or Workspace tab and choose Folder
History. In the right pane, P4V lists changelists that affected the folder, for example:

3 Falder Histary

Fievizion [Changelist]

(#7965
(#7383
(#5543
(245075
[ 4557

oo

[rate Submitted Submitted By
2004/11/0915:12:14  tonyz
2004/11/03 095505 tonye
2004/058/25 15:36:20  bruno
2003/09/04 12:45:40  tonyz
2003/05/14 031951 tonyz

AN NE IR 121097 been

Description
asdf
fix file type
explicit path to add to main.
Add search feature
Adding first files

A b A

2. Todisplay the changes that occurred between two revisions of a folder, drag and
drop one of the revisions on the other.

P4V displays the changes as shown in the following figure. This example shows that,
between the selected revisions, a file was edited and checked in. File highlights are color-
coded to indicate additions, changes, and deletions. Expand folders and scroll to locate
changes of interest. To skip to the next or previous change, click the right and left arrows.

Click to browse changes.

B Folder Diff (play:1999, tiinyz)

B Do|& o o @ Unique files: 13 [] File differences: 1
Path: wkfsturnatf...(@changelist 45527) Unique Files: 13 Path: spotfsturnat). ..(@changelist 407700 Unique Files: 0
= 3 newnir = O diff o’
- = O dff1
|4 testpland#1 |8 testplan#1

Revision:

Date submitted:
Submitted by:
Action:

Description:

& [ folderFilealpha
& [ folderFileTest

Details | Integrations

& [ folderFilealpha
& [ folderFileTest

Labels | Preview Details | Integrations
epotisturner/diff 1 /newDirjalphaFile# 1 Revision:
S0:02PM Changelist: 40839 Date submitted:
Perforce filetype text Submitted by:
add File size: 0.0KB Action:
Description:

Labels | Preview

Changelist:
Perforce filetype

File size:

18
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Important and Useful Features

Important and Useful Features

Among the many features provided by P4V, the following are especially useful:

¢ Tooltips: to get more information about an object, place your mouse cursor over it. P4V

displays a popup dialog containing more details.

¢ Drag and drop: P4V includes numerous drag and drop shortcuts for common

operations.

e File views: P4V enables you to preview graphics files using thumbnails.

¢ Tear off windows: to create a separate window displaying a specification you want to
keep on display, you can tear it off.

The following sections provide more details.

Tooltips

P4V provides tooltips for many objects on the screen. For example, to display the status of
a file, hold the mouse cursor over the file in the left pane. P4V displays a tooltip like the

following one.

bazzled HO/M <tests
bedazzled #0/1 <test

B barley.tst #3/3 <text:

barley, bt
Checked out in default changelist.

Another example: to display a changelist description, click @ in the toolbar and hold the
mouse cursor over the changelist in the right pane. There are tooltips for all the P4V

buttons, too.

Drag and drop

P4V provides drag and drop shortcuts for common tasks. Drag and drop can simplify
operations on large groups of files. For example, to check out all the files in a folder, drag
the folder to a changelist. To diff two files, drag one to the other. For details about drag
and drop shortcuts, refer to the P4V online help.

Perforce 2008.1 Getting Started with P4V
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Important and Useful Features

File views

If you use Perforce to manage graphics files, P4V’s thumbnail views enable you to
preview the files. To display thumbnails, click the Files tab in the right pane, then select
the desired thumbnail size from the title bar.

Lizt

Sx?

Large Thumbnail [160=160]
b edium Thurmbnail [120:120]
v Small Thurmbnail [30+30]

P4V displays thumbnails as shown in the following example.

21 play:1999, tonyz - Perfarce P4V

Fle Edt Wew Connection Took indow Help
. N uy - p IS &
HE 4ERF2 JEEAAAEHDIAS O
| Hdlepotjarchiimages] | W,
T8 Depot Tree W, F || & FiesinFolder 3. @ 3
(3 tonyz-test vl ~
3 Archis Test 2 ~
O archie Testt ot
) archie_oswald ‘#
@ O archiet E , AR
0 archiez = -
Bl archies idventureBiglLef .. AdventureMap.gif adventuresteps...
O rchies
O archiehidden
= B Archisimages b
AdventureBigleft.jpg #0/1 « Detals | ChecksdOutBy | Freview
AdventureMap.gif #0/1 <ub
AdventureStep4OFf gif #01 Warkspace location:
AdventureStep4on.gif #0{1 Dispt lestion:
airfare_off.gif #0/1 <ubinar )
sitfars_on.gf #0/1 <ubinary Regscel
archie_AdventureBigleft. jpg Date modified:
bike.jpg #0/1 <ubinary> — I
book,gif #0/1 <ubinarys
bookImage.gif #0/1 <ubinar Typs:
dlimber jog #0/1 <ubinary> ;| | Perforce Flstype:
& | >
8 Depot B workspace & Fles A Pending |5 workspaces | (3 History
=2 Log
e Fstat -P -C -Olh fidepoti* [/depot/Archisimages ™ |/depot/main/™ ~
b4 depots
b dis -C fidepoty* [[depot/archisimagesi* Jjdepot/main/™ o
e Fstat -Ofdae -4 thumb jdepotisam/cherry/foo v

20
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Important and Useful Features

Tearing off tabs

To keep a tab open, you can undock it. For example, context-click a file and choose File
History, then choose Window > Tear Off. P4V opens a separate window for it, as shown
in the following figure.

€ History - aac-Project1.mpp (play:1999, tonyc)

Revision

File: |.-".-"dep0t.-"aac:-F'roiec:t1.mpp

Changelist | Date Submitted

= //depot/aac-Project!.mpp

Submitted By | Filetype | Description

Action:

Submitted by matt

edit

Drescription: azdf

9 8396 1A10/2005 3:03:17 PM matt binary azdf
g 8392 1/7/2005 7:37.55 P matt binary ghj
7839 1/7/2005 7:3242 P matt binary adf
E 8330 1/7/2008 7:29:47 PM - matt binary azdf
5 8389 1/7/2008 72726 P matt binary adf
4 8388 1/7/2008 71448 PM matt binary azdf
3 8387 1/7/2008 6:47:47 PM matt binary azdaf
2 BBE2 E/1/2004 2:08:41 PM  torwe binary test checkin
1 BBE1 BE/1/2004 2:07:34 PM  torwe binary test add
Details | Integrations ] Labels ] Preview ]
Rievigion: //depot/aac-Project]. mppi3
Date submitted:  1/10/2005 3:03:17 Pk Changelist: 8396

Perforce filetype:  binary

File size:

To restore it to the main window, choose Window > Dock Window.

Setting Preferences

To configure P4V, choose Edit > Preferences. The tabbed Preferences dialog is displayed.
In particular, the Editor tab enables you to associate applications with file types,
overriding any operating system associations. The Diff and Merge tabs enable you to
configure external applications, in case you prefer tools other than those that are bundled
with P4V.

Perforce 2008.1 Getting Started with P4V

21



Migrating from P4Win

Migrating from P4Win

If you're moving from P4Win to P4V, here’s a list of equivalent operations to help you in

your transition.
P4Win Menu ltem
Changelist>Describe...

Edit>Find File Matching Pattern...
Edit>Find File Under Selected Folder...
File>Add to Source Control...

File>Diff 2 Files, Folders or Revisions
File>Diff Client File vs. Depot File

File>Explore
File>Integrate Using Filespec or Branchspec

File>More>Check Consistency

File>Open for Delete
File>Open for Edit

File>Properties

File>Remove from Client

File>Rename

File>Resolve>Auto Resolve...
File>Resolve>Interactively... [Resolve]

File>Resolve>Schedule File for Resolve

P4V Menu ltem
Edit>Go To...

Use Go To to display any type of
specification (job, branch, and so on).

Edit>Find File...

Edit>Find File...

File>Mark for Add

Applies only to files in the Workspace Tree
Tools>Diff...

Tools>Diff...

Or context- click on file and choose Diff
Against Have Revision

File>Show in Explorer
File>Integrate...
Tools>Reconcile Offline Work...

Applies only to folders in the Workspace
Tree

File>Mark for Delete

File>Check Out

View>Files in Folder

File properties are displayed in the Details
pane at the bottom of the Files in Folder
view

File>Remove from Workspace
File>Rename/Move...

File>Resolve...

File>Resolve...

File>Get Latest Revision
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P4Win Menu Item

File>Revision History...

File>Sync>Sync to Head Revision
File>Sync>Sync...

File>View File...

Settings>Favorite Connections
Settings>Logout
Settings>Options...

Settings>Port Client User History
Settings>Switch Port Client User...

User>Set Password for (current user)...

View>Bookmarks

View>Client View of Depot

View>ClientSpecs

View>Entire Depot

View>Local View of Client Tree
View>Show Deleted Depot Files

P4V Menu Item
View>History

Alternatively context click on file and
choose File History

File>Get Latest Revision
File>Get Revision...

File>Open

Connection>Favorite Connections
Connection>Log Off
Edit>Preferences...
Connection>Open Recent
Connection>Open Connection...
ConnectionChange Password...
Tools>Bookmarks

View>Depot Tree

Restrict to client view by choosing
View>Filter Depot>Tree Restricted to
Workspace View

View>Workspaces
View>Depot Tree

Show the entire depot by choosing
View>Filter Depot>Entire Depot Tree

View>Workspace Tree

View>Filter Depot>Show Deleted Depot Files
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Next Steps

Next Steps

This guide helps you to start working with files using P4V and points out important basic
features, but P4V enables you to do much more: create jobs, branch groups of files, and
handle file conflicts that arise in team development settings.

Perforce superusers can perform administrative operations by choosing Tools >
Administration. Using the Administration tool, superusers can manage users and groups,
and their access to files and folders within the depot. Some administrative functions must
still be performed using the Perforce command-line client (p4). For details, see the Perforce
Command Reference and the Perforce System Administrator’s Guide.

To become expert with P4V:

¢ Consult the P4V online help and read the Perforce user documentation available from
the Perforce Web site.

e Use tooltips.

¢ Pay attention to the file icons and decorations in the left pane. The decorations and
icons display a great deal of information about the type and status of a file.

e Start reading the Log pane.

® Learn drag and drop shortcuts to simplify operations on large sets of files. For details,
read the P4V Shortcuts help topic.

e Use P4V views and filtering features to enable you to selectively display information.

To get the whole picture, read the P4V online help, Introducing Perforce and the Perforce
System Administrator’s Guide. The guides, which are available from the Perforce web site,
describe the full set of features that the Perforce Server provides. Perforce Technical
Support is always ready to help you, and there’s a thriving community of Perforce users
active on the perforce-users mailing list. Consult our web site for details.
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